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In This Guide…
This guide introduces you to the components of the Agilent 
N6430A Series WiMAX Protocol Test. It also shows you how 
to install and configure your Agilent N6430A Series WiMAX 
Protocol Test Software.

It defines the requirements of your computer(s). It shows 
you a step- by- step procedure for the installation of the 
required applications and how to inter- connect the 
computer(s) and E6651A Test Set.

The Agilent N6430A Series Help on the supplied CD contains 
more information about the Agilent N6430A Series website, 
and operation of the N6431A TTCN- 3 environment.

It contains the following Chapters:

1 About the Protocol Test System

2 Installation

3 Additional Information
N6430A series Installation and Getting Started Guide 3
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The Agilent N6430A Series WiMAX Protocol Test Overview

An example of the Agilent Mobile WiMAX Protocol Test 
System is shown in Figure 1. Depending on the 
configuration purchased, the system includes the N6430A 
Series WiMAX Protocol Test Software, and one or more 
E6651A Mobile WiMAX Test Sets.

The N6430A Series software includes the N6431A TTCN- 3 
Environment, together with N6432A, N6433A, N6442A 
and/or N6443A adaptors depending on the configuration 
selected. These components allow TTCN- 3 Test cases to be 
executed.

The E6651A contains RF and MAC layer emulation functions. 
The E6651A can emulate a WiMAX base station or mobile 
station, providing an RF interface to the user- supplied 
equipment under test.

Figure 1 Example WiMAX IUT Protocol Test Implementation
4 N6430A series Installation and Getting Started Guide
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The N6430A Series software provides logging within the 
TTCN- 3 environment. For more detailed MAC/PHY layer 
protocol logging, it is also possible to connect the Agilent 
N6421A Protocol Logging and Analysis software to the 
E6651A. 

It is recommended that the N6430A Series software and the 
N6421A protocol logging application should be loaded and 
run on separate computers and connected to the E6651A 
using a private Ethernet network. Separate Ethernet ports 
can be added to the computers if necessary to provide 
connection to a public or corporate Ethernet network while 
maintaining connection to the E6651A.

Many protocol test scenarios can be emulated using a single 
E6651A. For some handover test scenarios, it may be 
necessary to emulate more than one WiMAX cell. Additional 
E6651As can be added to the system and controlled by a 
single instance of N6430A Series software to build up 
multi- cell systems. 

The currently supported WiMAX protocol testing 
methodologies require user control of the equipment under 
test. In the future, the WiMAX standard will expand to 
enable future revisions of the N6430A Series software to 
control the equipment under test by means of a standardized 
Test Interface (TI).
N6430A series Installation and Getting Started Guide 5
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About the Protocol Test System

This section provides some background to the Agilent 
implementation of a Protocol Test System. It shows you a 
block diagram of a Protocol Test System and how that is 
implemented with the Agilent N6430A Series and N6421A 
applications, and the E6651A WiMAX Test Set.

Block Diagram Implementation

The protocol test system block diagram is based closely on 
TTCN- 3 (Test and Testing Control Notation version 3) 
industry standards. 

The N6431A TTCN- 3 Environment provides a graphic user 
interface and software framework for other components of 
the system. The tool enables TTCN- 3 test cases to be loaded, 
edited or created, compiled and executed. It includes logging 
functions and the ability to automate sequences of tests or 
campaigns. The N6431A is based on Testing Technologies IST 
GmbH’s TTWorkbench product. 

WiMAX PCT TTCN- 3 test cases can be portable from one 
test platform to another. To enable test case portability, the 
functions available to a TTCN- 3 programmer through the TRI 
(TTCN- 3 Run Time Interface) have been standardized by 
ETSI and the WiMAX Forum™.

N6432/3A and N6442/3A include adaptors that connect the 
standardized TRI interface available to programmers to the 
unique implementations of MAC and PHY contained within 
the E6651A Mobile WiMAX Test Set. The SA (System 
Adaptor) provides a message portal to enable TTCN- 3 
programs to send and receive protocol messages directly to 
the MAC layer within the E6651A. The PA (Platform 
Adaptor) provides TTCN- 3 programs with a selection of 
External Functions. External Functions are defined by ETSI 
and implemented by a combination of unique software 
components within the PA and the E6651A. N6432/3A and 
N6442/3A also contain the message coder/decoder (Codec). 
10 N6430A series Installation and Getting Started Guide
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The Codec uses information from the IEEE 802.16 standards 
to encode and decode MAC messages using parameters with 
values defined within the TTCN- 3 test cases to a form that 
can be utilized directly by the protocol stack within the 
E6651A.

Figure 2 Agilent N6430A Series Implementation

Test cases written in the TTCN- 3 language are compiled to 
form the TE (TTCN- 3 Executable). WiMAX conformance test 
cases are created for the WiMAX Forum by ETSI. You can 
also create your own TTCN- 3 test cases.
N6430A series Installation and Getting Started Guide 11
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Figure 3 TTCN-3 Environment

The E6651A Mobile WiMAX Test Set exchanges messages 
with the SA and PA in the N6430A Series PC- based system 
using a proprietary protocol carried over a private Ethernet 
connection. The Test Set contains an implementation of the 
IEEE 802.16 protocol MAC (Media Access Control) layer and 
PHY (Physical) layer that includes an RF interface that can 
be used to connect to the equipment under test. When 
operated as a stand- alone Test Set, the E6651A MAC layer 
operates autonomously to emulate a WiMAX base station. 
When operated in TTCN- 3 mode, and connected to the 
external N6430A Series system, the Test Set’s upper MAC is 
disabled and replaced by the functionality of the TTCN- 3 
script being executed within the N6430A Series environment. 
In this mode, the system can emulate either a Mobile Station 
or a Base Station.

The N6421A Protocol Logging Application can be connected 
to the E6651A Mobile WiMAX Test Set to capture MAC and 
PHY message exchange. The Protocol Logging Application 
12 N6430A series Installation and Getting Started Guide
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can operate with the E6651A in either a stand- alone 
configuration, or in configurations where the E6651A is used 
with the N6430A Series system.

Figure 4 Agilent N6421A Protocol Logging and Analysis

TTCN- 3 industry terminology collectively describes the 
N6430A Series and E6651A Mobile WiMAX Test Set as the 
‘Lower Tester’. In this context, the protocol IUT 
(Implementation Under Test) is defined as the MAC protocol 
component within the Equipment under test (Mobile Station 
or Base Station). Other components exist within the User 
Equipment under test to support the testing of the IUT 
protocol. These include a user interface required to support 
the execution of some test cases serving as a TTCN- 3 ‘Upper 
Tester’. In the future, the WiMAX Forum will standardize an 
Ethernet- based connection between the test system and IUT 
to enable tests to be fully automated.
N6430A series Installation and Getting Started Guide 13
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Overview

Several software products and components are required to 
complete the Agilent N6430A Series WiMAX Protocol Test 
and Development System. 

This chapter provides a step- by- step guide to the installation 
of the N6430A Series software and also shows you how to 
ensure your Agilent E6651A WiMAX Test Set has the 
required firmware.

Please Check

Before proceeding, please confirm you have the following:

• Agilent E6651A WiMAX Test Set with the appropriate 
firmware revision. (Refer to “Step 7 -  E6651A Test Set 
Firmware” on page 37)

• A computer meeting the requirements specified in 
“Minimum Computer Requirements” on page 17

• Ethernet hub or switch and LAN cables

• N6431A CD- ROM for installation of the TTCN- 3 
environment.

• N6431A entitlement certificate for license redemption

• N6432A Test Adaptor installation CD- ROM

• N6432A/N6442A Test Adaptor USB license key

• Entitlement certificate for developer contract (if ordered):

• N6432A/N6442A- 1TY 12 month developers contract for 
Wave 1 updates and Wave 2 upgrades

• Entitlement certificate for Wave 1 validated release and 
contract (if ordered):

• N6433A/N6443A- 1TP Wave 1 validated release, and 
N6433AN6443A- 1TY 12 months maintenance contract 
for Wave 1 validation updates.

NOTE These Installation instructions are for both Mobile and Base Station Test.
16 N6430A series Installation and Getting Started Guide
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Minimum Computer Requirements

The N6430A Series installation computer should meet the 
minimum requirements specified for successful operation of 
the software.

Requirements

Processing large amounts of time critical data is an inherent 
requirement of the conformance test system. A high 
performance desk- top style computer with expansion 
capacity for additional Network Interface Cards (NIC) or 
adaptors is recommended.

Minimum System Requirements

Operating
System

Computer running Windows XP or Windows 2000.

Communication
with Test Set(s)

Ethernet.

RAM (Memory) Minimum 2 GB RAM.

Processor 2.0 GHz Intel Pentium® or equivalent, dual core preferred.

Disc Space N6431A TTCN- 3 Environment -  at least 170 MB

Java Runtime Environment -  at least 300 MB

N6432A/N6442A Test Adaptors -  at least 50 MB 

Optional

Additional Network Interface Cards (NIC) or adaptors if 
connection to public or corporate network is required.

NOTE Consideration for storage space should also be given for subsequent 
downloaded releases of N6432A/N6442A updates, development and 
validated scripts, and all supporting documentation, 
N6430A series Installation and Getting Started Guide 17
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Installation

The N6432A/N6442A software requires that the N6431A 
TTCN- 3 environment is installed. If you have not already 
done so, install the N6431A on your selected computer using 
the instructions below.

Step 1 - License Redemption

N6431A TTCN Environment License Redemption

The N6431A TTCN- 3 environment software (TTworkbench) is 
provided through collaboration with Testing Technologies IST 
GmbH. Agilent provide two options for TTworkbench 
products:

• N6431A- 1FP TTCN- 3 Environment, execution only

• N6431A- 2FP TTCN- 3 Environment, developer

An entitlement certificate for one of these options is 
required to redeem your license. License information is 
required during the installation process.

Entitlement certificates are also required for each of the 
N6432A, N6433A, N6442A, and N6443A product you have 
purchased. 

Redeeming your
Licenses

The license redemption procedure is similar for all products 
and requires that you have all or some of the following 
information readily available:

• Installation computer Hostname and LAN adaptor MAC 
address

• Order Number for your N6431A license
18 N6430A series Installation and Getting Started Guide



Installation 2

5972-3402.book  Page 19  Wednesday, February 6, 2008  1:44 PM
Determine
Hostname and
MAC Address

To find the Hostname and MAC address of the LAN adaptor 
on your computer proceed as follows:

1 Click Start > Run and enter cmd in the Run window as 
shown.

Figure 5 Run Window

2 In the command window, enter ipconfig /all to list 
information about your network adaptors, including the 
Host Name and MAC address (known as the physical 
address), a 12 digit hexadecimal number. 

In the example shown in Figure 6, the host name is 
“ipsc1046” and the MAC Address is 00- 04- 76- 4E- 26- 40.

Figure 6 Command Window

3 To redeem your license, go to the following web site: 
http://www.agilent.com/find/softwarelicense. Enter your order 
number and certificate entitlement number. Follow the 
N6430A series Installation and Getting Started Guide 19
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on- screen instructions. When prompted, enter your 
hostname, a single character space, and your 12 digit 
MAC address with no spaces between the hexadecimal 
numbers as shown in Figure 7.

Figure 7 Entering Hostname and MAC Address

On completion of this process an e- mail is sent to you with 
an “order_number_xyz.lic” attachment. This file is the license 
file and is required during the installation if the TTCN- 3 
environment and should be saved to a suitable location.

NOTE An instrument serial number is not required for this type of license. You 
can leave the instrument serial number field empty.

NOTE It is recommended that you save all license files to a convenient but 
secure location.
20 N6430A series Installation and Getting Started Guide
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Alternative Process

If you cannot access your e- mail account, you can:

1 Complete Steps 1 to 3 as above.

2 On the License website, click Redemption Options.

3 Right click the license file and select Save As...

4 Save the license file to a suitable location.

N6432A, N6433A, N6442A, and N6443A License Redemption

Entitlement certificates are also required for each of the 
N6432A, N6433A, N6442A, and N6443A product you have 
purchased. 

Repeat the procedure for each required license.

Redeeming your
Licenses

The license redemption procedure is similar for all products 
and requires that you have all or some of the following 
information readily available:

• Order Number for each product license

• USB license key serial number (for N6432A/N6433A or 
N6442A/N6443A)

1 To redeem your licenses, go to the following web site: 
http://www.agilent.com/find/softwarelicense. 

2 Enter your order number and certificate entitlement 
number. Follow the on- screen instructions. 

3 When prompted, enter your USB license key serial 
number.

On completion of this process an e- mail is sent to you with 
an “order_number_xyz.lic” attachment. This file is the license 
file and is required during the installation if the TTCN- 3 
environment and should be saved to a suitable location.

NOTE It is recommended that you save all license files to a convenient but 
secure location. Copy files to C:\Program Files\Agilent\N6430A Series 
Utilities\USB License Key Utilities only when required for updates. 
Remove the files from the update location afterwards.
N6430A series Installation and Getting Started Guide 21



2 Installation

5972-3402.book  Page 22  Wednesday, February 6, 2008  1:44 PM
Step 2 - Installing the N6431A TTCN-3 Environment

The latest N6431A TTCN- 3 Environment installation is 
available for download from the 
www.agilent.com/find/pctdownloads website. This website is 
protected by password. Your unique access code can be 
found in the e- mail you received containing your N6432A, 
N6433A, N6442A, or N6443A license file.

Procedure

1 Browse to www.agilent.com/find/pctdownloads and select 
Other Software Updates.

2 Use the access code supplied in the e- mails received 
following “N6432A, N6433A, N6442A, and N6443A License 
Redemption” on page 21 to access the downloads page.

3 Download version 1.1.1.1.2 of the N6431A. The installation 
file is setup_N6431A-2FP_1.1.1.1.2.exe.

4 When the download is complete, run the downloaded 
setup file.

5 Follow the displayed instructions.

6 When prompted by the license window, Browse to the 
“order_number_xyz.lic” file previously delivered to you by 
e- mail during the license redemption procedure.

Both the TTworkbench and N6432A/N6433A/N6442A/N6443A 
software require the installation of JDK (Java™ SE 
Development kit). Version 6 Update 3 is installed. The first 

NOTE The Agilent WiMAX MS Protocol Test application uses a specific version 
of TTworkbench. Even if you already have TTworkbench installed, 
installation of the N6431A is required.

NOTE If you have been supplied with a demonstration “license.dat” file this 
should be selected here by changing the File Type to All Files in the 
license window.
22 N6430A series Installation and Getting Started Guide
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step in the install process is the installation of the Java™ 
software. 

7 Click Next to continue with the installation.

The installation proceeds by first installing the Java 
Development environment followed by the TTCN- 3 
environment.

8 When the license entry window is displayed for the 
second time the license file field has already been 
populated with the license information selected in step 3. 

9 Click Next to continue.

10 Click Finish to complete the installation.

NOTE This installation may add another version of JDK to your Add/Remove 
Programs if you already have a different version installed.
N6430A series Installation and Getting Started Guide 23



2 Installation

5972-3402.book  Page 24  Wednesday, February 6, 2008  1:44 PM
Un-installation

If un- installation is required, proceed as follows:

a The Java JDK software can be un- installed using 
Add/Remove Programs in Windows.

b The TTworkbench can be un- installed by pressing:
Start > All Program > Testing Technologies > TTworkbench > 
TTworkbenchuninstaller.
24 N6430A series Installation and Getting Started Guide
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Step 3 - Installing N6432A Mobile Station Test Adaptor (if 
ordered)

The N6432A Mobile Station Protocol Test Adaptor requires 
that the N6431A TTCN- 3 Environment is installed. If you 
have not already done so, refer to “Step 2 -  Installing the 
N6431A TTCN- 3 Environment” on page 22

N6432A Installation Components

The N6432A installation installs the following items on your 
computer:

• USB License Key driver and utilities (available from the 
Start menu)

• N6432A Protocol Conformance Test Adaptor

Procedure

The N6432A Test Adaptor may have been delivered to you 
on CD- ROM. For the most up- to- date version Agilent 
recommends that you download it from the PCT download 
website as follows:

1 Browse to www.agilent.com/find/pctdownloads and select 
Software Updates for MS Developers.

2 Use the access code supplied in the e- mails received from 
“N6432A, N6433A, N6442A, and N6443A License 
Redemption” on page 21 to access the downloads page.

3 Download the most recent qualified or beta version of the 
N6432A. The installation file is N6432A_A.5.0.1.0.exe or 
later.

4 When the download is complete, run the downloaded 
setup file.

5 When prompted, enter your details and click to accept the 
license agreement.

NOTE Before proceeding, please ensure you have your USB license key and 
redeemed license details available.
N6430A series Installation and Getting Started Guide 25
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6 Follow the displayed instructions.

7 One of the first steps of the process is the installation of 
the SUT (system under test) adaptors. You are asked to 
confirm the root directory which you would like to use 
for saving the adaptor software. The default root directory 
is:
C:\Program Files\Agilent\WiMAX MS Protocol Test 

8 The program installs the adaptor.

Depending on the purchased products and options, your 
license enables use of one or both the development and/or 
conformance releases. The directory structure for the 
individual releases is as follows:

• Developer versions -  root_directory\N6432A Development 
Releases\N6432A_A.w.x.y.z

• Conformance versions -  root_directory\N6433A 
Conformance Releases\N6433A_V.w.x.y.z

The releases are numbered as follows:

• A.w.x.y.z releases are qualified developers releases

• X.w.x.y.z releases are pre- qualified developers releases

• V.w.x.y.z releases are WiMAX Forum® validated releases.

9 The N6432A install program also installs the drivers for 
your USB license key. Check the USB License key install 
box to perform the installation of the Sentinel Protection 
Installer software. 

10 Plug in your USB license key and check the installation 
has worked. 

• If your key shows a green light it is successfully installed.

• If a window showing “Welcome to the Found New Hardware 
Wizard” appears, the installation has not been successful. 
Un- install and re- install the N6432A software. 

NOTE The install program only installs a development release.
26 N6430A series Installation and Getting Started Guide
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Uninstallation

The Agilent N6432A Test Adaptor and Sentinel Protection 
Installer software can be un- installed using Add/Remove 
Programs in Windows.
N6430A series Installation and Getting Started Guide 27
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Step 4 - Installing N6442A Base Station Test Adaptor (if 
ordered)

The N6442A Base Station Protocol Test Adaptor requires 
that the N6431A TTCN- 3 Environment is installed. If you 
have not already done so, refer to “Step 2 -  Installing the 
N6431A TTCN- 3 Environment” on page 22.

N6442A Installation Components

The N6442A installation installs the following items on your 
computer:

• USB License Key driver and utilities (available from the 
Start menu)

• N6442A Protocol Conformance Test Adaptor

Procedure

The N6442A Test Adaptor may have been delivered to you 
on CD- ROM. For the most up- to- date version Agilent 
recommends that you download it from the PCT download 
website as follows:

1 Browse to www.agilent.com/find/pctdownloads and select 
Software Updates for BS Developers.

2 Use the access code supplied in the e- mails received from 
“Step 1 -  License Redemption” to access the downloads 
page.

3 Download the most recent qualified or beta version of the 
N6442A. The installation file is N6442A_A.5.0.1.2.exe or 
later.

4 When the download is complete, run the downloaded 
setup file.

5 When prompted, enter your details and click to accept the 
license agreement.

NOTE Before proceeding, please ensure you have your USB license key and 
redeemed license details available.
28 N6430A series Installation and Getting Started Guide
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6 Follow the displayed instructions.

7 One of the first steps of the process is the installation of 
the SUT (system under test) adaptors. You are asked to 
confirm the root directory which you would like to use 
for saving the adaptor software. The default root directory 
is:
C:\Program Files\Agilent\WiMAX BS Protocol Test 

8 The program installs the adaptor.

Depending on the purchased products and options, your 
license enables use of one or both the development and/or 
conformance releases. The directory structure for the 
individual releases is as follows:

• Developer versions -  root_directory\N6442A Development 
Releases\N6442A_A.w.x.y.z

• Conformance versions -  root_directory\N6443A 
Conformance Releases\N6443A_V.w.x.y.z

The releases are numbered as follows:

• A.w.x.y.z releases are qualified developers releases

• X.w.x.y.z releases are pre- qualified developers releases

• V.w.x.y.z releases are WiMAX Forum® validated releases.

9 The N6442A install program also installs the drivers for 
your USB license key. Check the USB License key install 
box to perform the installation of the Sentinel Protection 
Installer software. 

10 Plug in your USB license key and check the installation 
has worked. 

• If your key shows a green light it is successfully installed.

• If a window showing “Welcome to the Found New Hardware 
Wizard” appears, the installation has not been successful. 
Un- install and re- install the N6442A software. 

NOTE The install program only installs a development release.
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Un-installation

The Agilent N6442A Test Adaptor and Sentinel Protection 
Installer software can be un- installed using Add/Remove 
Programs in Windows.
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Step 5 - Redeem License for Developers’ Contract 
(if ordered)

If, as a developer, you plan to write and compile scripts, you 
require an N6432A- 1TY or N6442A- 1TY license redemption 
certificate. This entitles you to access the web and use 
development releases for a period of 12 months. The 
licensing of this entitlement is via the USB license key.

Check Entitlement Status

You can check the current entitlement status of your USB 
license key using installed utilities found in the Start menu. 
Click Start > Agilent Mobile WiMAX Test Set > N6430A Series Utilities 
>Read USB License Key to view the USB license key contents.

A window similar to that shown in Figure 8 provides the 
serial number of your USB license key and licenses. The 
serial number is also printed on the key.

Figure 8 USB License Key Reader Display
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Developers’ License Redemption

To redeem your License, proceed as follows:

1 Go to the following secure web site:
http://www.agilent.com/find/softwarelicense.

2 Enter your order number and certificate entitlement 
number.

3 Follow the displayed instructions, entering your USB 
License key serial number when prompted.

4 On completion of this process, an E- mail with an 
order_number_identity_number.lic attachment is sent to 
you. This is the license file

5 Ensure the USB license key is inserted and click Start > 
Agilent Mobile WiMAX Test Set > N6430A Series Utilities > Update 
USB License Key to update your entitlement in the USB 
license key.

6 When updated, the USB License Key update window is 
displayed:

NOTE It is recommended that you save all license files to a convenient but 
secure location. Copy files to C:\Program Files\Agilent\N6430A Series 
Utilities\USB License Key Utilities only when required for updates. 
Remove the files from the update location afterwards.

NOTE For Mobile Station test, ensure that only your N6432A License key is in the 
computer. No other license key should be connected. Likewise, for Base 
Station test ensure that only the N6442A License key is connected.
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7 Click Start > Agilent Mobile WiMAX Test Set > N6430A Series 
Utilities >Read USB License Key to check that you now have 
entitlement to use the developer's web releases. After 
updating your USB key, confirm the information is similar 
to that shown in Figure 9.

Figure 9 Updated USB License Key Information

Developer's releases are available at 
http://www.agilent.com/find/pctdownloads. 
This site is password protected. A unique password is 
provided to you with your software license e- mail.
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Step 6 - Redeem License for Wave 1 Validated Release and 
Contract (if ordered)

If, as a conformance tester, you plan to run pre- compiled 
scripts for conformance testing, you require entitlement 
certificates for both N6433A- 1TP and N6433A- 1TY or 
N6443A- 1TP and N6443A- 1TY. This entitles you to access 
the web and use validated conformance releases for a period 
of 12 months. The licensing of this entitlement is done via 
the USB license key.

Check Entitlement Status

To check the current entitlement status of your USB license 
key, click Start > Agilent Mobile WiMAX Test Set > N6430A Series 
Utilities >Read USB License Key. 

A window similar to that in Figure 10 shows the serial 
number of you USB license key. The serial number is also 
printed on the key.

Figure 10 USB License Key Reader Display

NOTE Check the download web site 
(http://www.agilent.com/find/pctdownloads) for availability of a 
validated release before redeeming this license. The password for the 
website is shown on your entitlement certificate. You do not need to 
redeem your license until there is a validated release available. 
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Wave 1 Validated Release License Redemption

To redeem your License, proceed as follows:

1 Go to the following secure web site:
http://www.agilent.com/find/softwarelicense.

2 Enter your order number and certificate entitlement 
number.

3 Follow the displayed instructions, entering your USB 
License key serial number when prompted.

4 On completion of this process, an E- mail with an 
order_number_identity_number.lic attachment is sent to 
you. This is the license file.

5 Ensure the USB license key is inserted and click Start > 
Agilent Mobile WiMAX Test Set > N6430A Series Utilities > Update 
USB License Key to update your entitlement in the USB 
license key.

6 When updated, the USB License Key update window is 
displayed:

NOTE It is recommended that you save all license files to a convenient but 
secure location. Copy files to C:\Program Files\Agilent\N6430A Series 
Utilities\USB License Key Utilities only when required for updates. 
Remove the files from the update location afterwards.

NOTE For Mobile Station test, ensure that only your N6432A License key is in the 
computer. No other license key should be connected. Likewise, for Base 
Station test ensure that only the N6442A License key is connected.
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7 Click Start > Agilent Mobile WiMAX Test Set > N6430A Series 
Utilities >Read USB License Key to check that you now have 
entitlement to use the validated web releases. After 
updating your USB key, confirm the information is similar 
to that shown in Figure 11.

Figure 11 Updated License Information

Wave 1 Conformance releases are available at 
http://www.agilent.com/find/pctdownloads. 
This site is password protected. A unique password is 
provided to you with your software license e- mail.
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Step 7 - E6651A Test Set Firmware

The E6651A WiMAX Test Set must have a version of 
firmware installed that supports the N6430A Series 
applications for both Base and Mobile Station test. 
Additionally, firmware updates may be essential to meet the 
requirements of new scripts released in the N6432A/N6442A 
software updates.

Mobile Station and Base Station test require different firmware

The E6651A WiMAX Test Set is normally configured in Base 
Station Emulation mode for mobile station test using the 
N6432A/N6433A test adapters. 

For Base Station test with the N6442A/N6443A adapters the 
Test Set must have the E6653A Mobile Station Emulation 
firmware installed and enabled.

Mobile Station
Test

Test Set firmware for N6432A/N6433A Test Adaptors

To check the version of the firmware installed on your 
E6651A, proceed as follows:

1 Ensure the Test Set has completed its start up sequence 
and the WiMAX Application has started.

2 Check the version -  it is displayed in the Firmware and 
Profile bar at the base of the display. 

E6651A Firmware version later than 5.1.0.11 is required to 
support the N6430A Series software.

NOTE You should always check the required configuration of software and 
firmware for each release of N6430A series applications by referring to the 
release notes supplied with the new release. Or, refer to the supported 
configurations matrix linked from the pct-downloads website for each 
N6430A series application.
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Download Firmware (if required)

Please ensure that you check the N6430A Series release 
notes at www.agilent.com/find/pctdownloads for information 
about E6651A Test Set firmware requirements. Downloads 
are available from the same website, 
www.agilent.com/find/pctdownloads.

Base Station
Test

Test Set firmware for N6442A/N6443A Test Adaptors

To enable Mobile Station Emulation, an E6653A- 1FP license 
must be redeemed and installed in the E6651A Test Set. 
E6653A Mobile Station Emulation firmware must also be 
installed in the Test Set and enabled.

E6653A-1FP License Redemption

To redeem your License, proceed as follows:

1 Go to the following secure web site:
http://www.agilent.com/find/softwarelicense.

2 Enter your order number and certificate entitlement 
number.

3 Follow the displayed instructions, entering your E6651A 
serial number when prompted. The serial number can be 
found on the rear panel label or from the Service Screen 
on firmware versions 5.3.1.0 or 6.3.1.0 or later.

4 On completion of this process, an E- mail with an 
order_number_identity_number.lic attachment is sent to 
you. This is the license file

NOTE It is recommended that you save all license files to a convenient but 
secure location. 
38 N6430A series Installation and Getting Started Guide



Installation 2

5972-3402.book  Page 39  Wednesday, February 6, 2008  1:44 PM
E6653A-1FP License Installation

To install the License in the E6651A proceed as follows:

1 On a USB flash memory stick, create a folder called 
setup.inno as the root directory.

2 Copy the license file to the setup.inno folder on the 
memory stick.

3 In the setup.inno folder, rename the license file as 
license.lic.

4 Ensure you have E6651A firmware version 5.2.1.1 or later 
installed in your E6651A Test Set. (Refer to step 2 on 
page 37.

5 Insert the memory stick into one of the USB ports on 
your E6651A.

6 On the E6651A, press the System key followed by the 
Service key and select Update License from the softkey 
menu. Navigating to a second page of softkeys in the 
System menu may be required to access the Service key.

7 Wait approximately 10 seconds for the license to be 
installed successfully before installing the E6653A Mobile 
Station emulation firmware.

E6653A Mobile Station Emulation Firmware Installation

Install the E6653A firmware as follows:

1 Go to the following secure web site:
http://www.agilent.com/find/pctdownloads and select Other 
Software Updates.

2 Use the access code supplied in the e- mails received from 

3 “N6432A, N6433A, N6442A, and N6443A License 
Redemption” on page 21 to access the downloads page.

4 Download E6653A version 5.2.0.8 (the installation file is 
E6653A_5.2.0.8.zip).

5 When the download is complete, browse to the “E6651A 
Software update procedure” located in the Other Information 
and Support section of the 
http://www.agilent.com/find/pctdownloads website to find 
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the procedure to install the E6653A in the E6651A Test 
Set.

NOTE Before proceeding, please ensure you have your USB license key and 
redeemed license details available.
40 N6430A series Installation and Getting Started Guide



Installation 2

5972-3402.book  Page 41  Wednesday, February 6, 2008  1:44 PM
Step 8 - Connecting the System

For operation with the N6430A Series applications the 
E6651A and application host computer must be connected 
via an Ethernet hub or switch. 

Figure 12 Example Interconnection

Procedure

Before connecting the set- up, check and configure the IP 
address of your computer. Settings are required as follows:

• IP Address: 10.253.18.111

• Subnet mask: 255.255.0.0
N6430A series Installation and Getting Started Guide 41



2 Installation

5972-3402.book  Page 42  Wednesday, February 6, 2008  1:44 PM
You can check the IP address details on your PC by opening 
a command window. 

1 Click Start > Run and enter cmd at the prompt.

Figure 13 Run Window

2 In the command widow, enter: ipconfig

Figure 14 IP Address and Subnet Mask Check

3 If the IP settings are not as defined at the beginning of 
the procedure, change them by clicking Start > Control Panel 
> Network Connections. 

4 Right click on your Local Area Connection and select 
Properties.

5 Scroll down to find and click to highlight Internet protocol 
(TCP/IP)

6 Click the Properties button. 
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7 Check “Use the following IP address” and enter the numbers 
shown in Figure 14.

Figure 15 IP Address and Subnet Mask Entry

8 Connect the E6651A to your PC using the following 
diagram for guidance. 

9 For N6432A/N6433A Base Station test, switch the E6651A 
to BSE mode to check the network settings. When ready, 
return to MSE mode.

NOTE Note this must be done to set the IP address in the E6651A.
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Figure 16 Interconnections

E6651A Test Set
LAN Settings

10 Check the IP address on your E6651A by pressing System, 
More 2/2. The IP address and subnet mask values are 
displayed in the Network Setting field.

Figure 17 Test Set IP Address and Subnet Mask
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11 The following LAN settings are required:

• IP Address -  10.253.18.79

• Subnet mask -  255.255.0.0

• Gateway -  10.253.18.1

12 If you need to change the settings, proceed as follows:

a Press the Network Setting softkey.

b Press the softkey associated with the parameter you 
need to change.

c Use the numeric keys to enter the required value and 
press Enter.

d Use the Arrow keys to select the next value to be 
changed and repeat the previous steps.

e When you have configured all the settings press Apply.

Check the
Connection

13 Check the connection by opening a command prompt 
window on the computer connected to the E6651A Test 
Set -  click Start > Run and type cmd into the Run Window.

14 Enter ping 10.253.18.79 at the command prompt. 

Confirm lines displayed starting with the text - Reply from 
10.253.18.79 as shown in Figure 18. Your computer and 
E6651A's network settings have been configured correctly 
and your computer can transfer packets to the E6651A 
successfully.

Figure 18 Successful Ping Command and Return
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If the computer and Test Set LAN configurations are 
incorrect, the Ping command results in a time out.

Figure 19 Ping Time-out
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Final Steps 15 If you are performing Base Station tests return the 
E6651A Test Set to Mobile Station Emulation mode.

16 To complete the installation process, make the following 
settings in the E6651A:

a Press System > TTCN mode [ON]

17 The Firewall in your computer must be disabled. You can 
do this by pressing: 
Start > Control Panel > Administrative Tools > Services to display 
the Services window.

Figure 20 Service Window

18 Select Windows Firewall/Internet Connection Sharing and click 
the Stop button in the Tool Bar.
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Step 9 - Start and Configure the Workbench Application

To check your installation, start and configure the TT 
Workbench application, proceed as follows:

1 Insert your N6432A or N6442A USB License Key in your 
computer.

1 Double click the TTworkbench icon on your 
desktop.

2 The TTworkbench Workspace Launcher window asks you for 
a path to use as the workspace folder. 

Figure 21 Workspace Launcher

3 Click Browse... to open the Select Workspace Directory 
window.

4 Navigate to and highlight the your own <user> folder and 
click Make New Folder.

NOTE The workspace folder is used by the Workbench application. 
It is recommended that you create folders for each test 
adapter, for example N6432A or N6442A. You should also 
create a folder for each new release within each test adapter 
folder.
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5 Enter the required folder name, for example; 
N6442A_X.5.0.1.6_workspce_1.

 

Figure 22 Adding a New Workspace Folder Example

CAUTION Attention is required when creating workspace folders. It is strongly 
recommended that you use the paths and folders shown in this 
procedure. DO NOT select the installation folders of the test adaptors 
as the workspace.
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6 Click OK to continue.

Figure 23 New Workspace Selected

7 The TTworkbench application starts and displays a 
welcome screen.

Figure 24 Wokbench Welcome Window

8 Now turn off the Build Automatically feature. Click 
Window > Preferences... > and click the ‘+’ beside General. 
Click Workspace and click on Build Automatically to deselect it 
(no  displayed in the check box as shown).
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Figure 25 Preferences Workspace Window

9 Click Apply.

10 Click Window > Preferences > Expand “General” and “Editors”.

11 Click Editors > File Associations. 

12 Click Add... and enter *.ttcn in the entry window and click 
OK.
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13 Click on *.ttcn and Add... the TTCN-3 Core Language Editor and 
TTCN-3 Core Language Viewer as associated editors for *.ttcn 
files.

Figure 26 Associating Editors

14 Click on File > Import > General (double- click to expand this 
icon) > Existing Projects into Workspace > Next.
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For N6432A/N6433A Mobile Station test

1 Browse to find the directory for installed release. For 
example, the N6432A:-  c:\Program Files\Agilent\WiMAX MS 
Protocol Test\N6432A Development Releases \N6432A_A.5.0.1.0 
(Note this is not the TT workspace directory, but the 
location of the N6432A software when installed in “Step 3 
-  Installing N6432A Mobile Station Test Adaptor (if 
ordered)” on page 25).

2 Check Copy projects into workspace.

3 Click Finish.

For N6442A/N6443A Base Station test

1 Browse to find the directory for installed release. For 
example, the N6442A:-  c:\Program Files\Agilent\WiMAX BS 
Protocol Test\N6442A Development Releases \N6442A_A.5.0.1.2 
(Note this is not the TT workspace directory, but the 
location of the N6442A software when installed in “Step 4 
-  Installing N6442A Base Station Test Adaptor (if 
ordered)” on page 28).

2 Check Copy projects into workspace.

3 Click Finish.

Connect to the DUT

Prior to running the test case, you should connect your DUT 
to the E6651A Test Set and ensure you complete the 
following:

1 Load the correct profile for your DUT (The profile 
manager is located under the Test Set system menu).

2 Establish an RF connection between your DUT and the 
Test Set.

3 Turn both the RF power and modulation ON.

Base Station
Test Only

4 For N6442A and N6443A Base Station test only:

a Ensure that the Base Station under test is operating

b Press Frequency and adjust the frequency of the E6651A 
Test Set to match the frequency of the BS under test
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c Press Mode > Mobile Station Emulator

d Press Emulator Start

e Press Amplitude and adjust the Test Set source 
amplitude to be within range of the input power level 
requirements of the BS under test

f Adjust the receiver attenuation until the “SYNC” field 
displays “3” and the “Frame Error” field shows “0”

g If desired, verify correct RF parameters by pressing 
Mode > Mobile Station Emulator > Connect to perform 
network entry

h Press Mode > Mobile Station Emulator > Emulator Stop

Both MS and
BS Test

5 For both MS and BS Test, turn TTCN mode ON (located 
under the Test Set system menu).
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For N6432A/N6433A Mobile Station Test

1 Click the Go to the workbench icon.

2 Within the TTworkbench development perspective, expand 
the N6432A_A.5.0.1.0 directory, and then expand the ttcn3 
directory.

3 Double click the SampleScript_IR.clf file.

For N6442A/N6443A Base Station test Base Station Test

1 Click the Go to the workbench icon.

2 Within the TTworkbench development perspective, expand 
the N6442A_A.5.0.1.2 directory, and then expand the ttcn3 
directory.

3 Double click the SampleScript_IR_1A_8.75MHz.clf or 
SampleScript_IR_3A_10MHz.clf file as appropriate for DUT.

Both MS and
BS Test The TTworkbench application now changes to the execution 

pane and starts loading the test campaign (this may require 
a few minutes). During this process warnings are displayed 
if either you have failed to correctly connect with the 
E6651A or you have licensing issues.
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When the test campaign is fully loaded the SampleScript 
campaign is listed in the test case window. Expand on the 
campaign to see the actual test case. 

4 You can now run the Initial Ranging test case. To do this, 
click on the script running man at the top left corner of 
the management view.

Figure 27 Run Test
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5 After running the script, a screen similar to that below is 
displayed. This shows that the script has executed, and 
passed, with a graphical log of the message exchange in 
the lower right hand corner. 

Software updates for both Developer and conformance 
customers are available at 
www.agilent.com/find/pctdownloads. To access the software 
releases, you need to enter the password which is 
included in your license redemption E- mail. Each release 
is provided as an .exe installation file which operates in 
the same way as the test adaptor install described in 
“Step 3 -  Installing N6432A Mobile Station Test Adaptor 
(if ordered)” on page 25, or “Step 4 -  Installing N6442A 
Base Station Test Adaptor (if ordered)” on page 28. 

In addition, provided with each release is information about 
the TRI external functions and WiMAX TLVs 
(Type/Length/Value) which are supported. When you 
download the zip archive please extract all files into a 
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directory on your PC. This creates a directory with all of the 
T3 docs and allows you to view details regarding the 
external functions. Winzip is the recommended tool to 
extract files from this release information

In addition, the web site also provides links for firmware 
updates, TTWorkbench downloads and downloads for the 
N6421A Protocol Logging and Analysis software.
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Step 10 - Integrating the N6421A Protocol and Logging 
application

System Configuration Manager

If you are using the N6421A Protocol Logging and Analysis 
Application to log and analyze message traffic, use the 
System Configuration Manager to help configure the required 
IP addresses.

1 On the N6421A installation computer, click Control Panel > 
Network Connections.

2 Right- click the required connection to display the 
Properties.
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3 Highlight Internet Protocol (TCP/IP) and click Properties.

4 On the N6430A Series installation computer click Start > 
All Programs > Agilent Mobile WiMAX Test Set > N6430A Series 
Utilities > System Configuration Manager to open the following 
window. Copy the IP address displayed in step 3 into the 
N6421A IP address on the System Configuration Manager.

5 Open the N6421A Protocol Logging application and click 
File, Port Open. Ensure the E6651A IP address in the Port 
Open window matches that displayed in the System 
Configuration Manager. Double click to edit the IP 
Address if it is incorrect.

N6421A IP Address

E6651A IP Address
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Import PCT Message Logging into the TTCN-3 Environment

1 In the TTCN- 3 Workbench application right- click in the 
TTCN- 3 Projects window, select Import... and select Existing 
Projects into Workspace.

2 Click on Next, then Browse to open the Browse window.

3 Locate and highlight the PCT Logging application 
directory. (Default C:\Program FIles\Agilent\PCTLogging). 
Click OK.
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4 Confirm the path has been selected in the Import Projects 
window and click Finish.

Figure 28 PCT Logging folder selected.

5 Confirm PCT Logging is displayed in the Projects list.
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Add the PCT Logging plug- in to your project.

6 Highlight the required project in the Projects list. Right 
click and scroll to Properties. 

7 In the Properties window, highlight TTCN-3 Settings and 
select the TT3 plugins tab.
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8 Click Add Folder..., select PCT Logging and click OK.

9 Confirm the PCT Logging folder is displayed and click OK.
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Confirm the Logging operates whilst running the workbench 
environment.
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Responsibilities of the Customer

The customer shall provide:

• Access to the products during the specified periods of 
coverage to perform maintenance

• Adequate working space around the products for servicing 
by Agilent personnel.

• Access to and use of all information and facilities 
determined necessary by Agilent to service and/or 
maintain the products. (Insofar as these items may 
contain proprietary or classified information, the 
customer shall assume full responsibility for safeguarding 
and protection from wrongful use.)

• Routine operator maintenance and cleaning as specified in 
the Agilent Operating and Service Manuals.

• Consumables such as replacement fuses, etc.
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The Agilent N6430A Series Support Web Site

Refer to the Agilent N6430A Series WiMAX Protocol Test 
website, www.agilent.com/find/pctdownloads for:

• License retrieval.

• Software updates.

• Installation Notes.

• Release Notes.

• E6651A Test Set firmware updates.

• Links to additional web sites such as ETSI Mantis system 
and the WiMAX Forum.

Figure 29 Agilent N6430A Series website

NOTE Some information and downloads are freely available on this site. 
Software downloads and some documentation are available only to 
Agilent N6430A Series customers. A login and password is required to 
access this information. For login information please refer to the e-mail 
containing your license file(s).
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Agilent Sales and Service Offices

In any correspondence or telephone conversations, refer to 
the Test Set by its model number and full serial number. 
With this information, the Agilent representative can quickly 
determine whether your unit is still within its warranty 
period.

You can visit our website: http://www.agilent.com/find/assist

UNITED STATES Agilent Technologies
(tel) 1 800 829 4444

CANADA Agilent Technologies Canada Inc.
Test & Measurement 
(tel) 1 877 894 4414

EUROPE Agilent Technologies
Test & Measurement 
European Marketing Organization
(tel) (31 20) 547 2000

JAPAN Agilent Technologies Japan Ltd. 
(tel) (81) 426 56 7832
(fax) (81) 426 56 7840

LATIN AMERICA Agilent Technologies
Latin America Region Headquarters, USA
(tel) (305) 267 4245
(fax) (305) 267 4286

AUSTRALIA and 
NEW ZEALAND

Agilent Technologies Australia Pty Ltd. 
(tel) 1-800 629 4852 (Australia)
(fax) (61 3) 9272 0749 (Australia)
(tel) 0-800 738 378 (New Zealand)
(fax) (64 4) 802 6881 (New Zealand)

ASIA PACIFIC Agilent Technologies, Hong Kong
(tel) (852) 3197 7777 
(fax) (852) 2506 9284
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